Remap of Zelda 1

Started by Ezka, December 29, 2016, 12:38:13 AM

Previous topic - Next topic
Hi guys, recently I was interested in actually learning how to use the solarus editor rather than just playing games people made with it. Because of that, I am currently working on remapping all of zelda 1: the over world, dungeons, and secrets. I will only be making it so you can walk around and explore, however I may(small chance) try and turn it into a remake further down the line. I have currently made a tiles for the over world, and mapped around 20 game screens.  I will keep you guys updated and how it goes.

The first Zelda isn't so hard to remake, in fact it is more easier to remake the NES Zelda on solarus then remaking ALTTP, but t's a good example to learn how the engine works.

Good luck.

Alright halfway done with mapping the over world. Also, quick question. Is it possible to move a map into a folder after it has been made? I have tried clicking and dragging but it hasn't been working. It isn't necessary but I like to organize. Thanks!

Try to change the "id" of the map. That's actually the folder location if I am not wrong.
"If you make people think they're thinking, they'll love you. But if you really make them think, they'll hate you."

If you plan to organize your maps, in your maps folder, you need to have in the same folder,

map.lua (if using a script)

Then declare it in the map editor

I have completed mapping the over world, and am in the process of linking the maps together and making them all traversable. However I have come across a problem after finishing link's sprite.

In "game_manager.lua", I changed hero:set_tunic_sprite_id from hero:set_tunic_sprite_id("main_heroes/eldran")
to links sprite i made: hero:set_tunic_sprite_id("Link/link").

When running the game, the sprite moves around fine but I can't get links head to touch anything. I think it might be because the original sprite used was 24 by 24, however links is only 16 by 16. If someone could provide some insight that would be nice, thanks!

Update, I just found out that the whole sprite is off. The sprite can also walk into wall blocks by the same amount it can't touch the other blocks

You have to modify the origin point of your sprites, in the sprites editor; that will shift the images and solve your problem. The best option for the "origin_y" coordinate is usually 13, but I can't confirm in your case.

I quote from the Lua API:
"The origin is the point of synchronization for sprites that have several animations or directions of different sizes, and for entity sprites that are larger than the entity itself."
(see ).
"If you make people think they're thinking, they'll love you. But if you really make them think, they'll hate you."

Thanks, I was a bit confused at first because the origin was centered. However I had to change it to 8 13 for it to work right.

Most of the time the correct origin is the center of the sprite (x), and the knee (y)

According to Chris, the default origin of a sprite is usually one half the distance of x, and 3 pixels from the bottom of y.


16 x 16 - origin is 8 x 13
32 x 32 - origin is 16 x 29

My tilesets page can be found here:

So I am currently working on moving the maps I have made into the alttp dev pack so I have more to relate to with christophos tutorials. However I have come across a problem when trying to start the game. I have changed the game:set_starting_location to h8 in initial_game.lua. However when starting the game nothing appears. Any suggestions?

Is there any error ? What happen? Are you on a map or black screen ?

Their are two things i have tried since

1) I have kept the normal game manager script from the original alttp. With that, nothing shows up on the game screen when I press play and two error messages show up on console:
Error: Failed to load script 'scripts/game_manager': [string "scripts/game_manager.lua"]:3: '(' expected near ':'
Error: In main: [string "main.lua"]:6: module 'scripts/game_manager' not found:

2) I copied the game maneger script from my original game file over and with that, the solarus logo shows up then disappears on the game screen, and 1 error message appears on console:
Error: In on_finished: [string "scripts/game_manager.lua"]:18: Cannot check savegame: no write directory was specified in quest.dat

Also, with both of the game manager scripts, this warning appears:

Warning: Cannot use quest size 320x240: this quest only supports 256x176 to 256x176. Using 256x176 instead.

I do not understand this however because I have set the minimum and maximum  to 256x176 making the normal size just that.

So, as you might see, there is something in game_manager that interrupt the process

There is a missing thing on the line 3 in your game_manager

and there is no folder set to save your savegame.
To do it, just do the following

If there is nothing, just put whatever you wat