1.4.4 on OS X (10.11.1)

Started by vedder9, November 11, 2015, 02:35:15 AM

Previous topic - Next topic
November 11, 2015, 02:35:15 AM Last Edit: November 11, 2015, 02:36:52 AM by vedder9
Anyone else having issues running the latest version on 10.11?

I'm able to run the previous version with no issues, but when I try to launch the Solarus Quest Editor v1.4.4 I'm presented with an error:

"Check with the developer to make sure Solarus Quest Editor works with this version of OS X. You may need to reinstall the application."

If you look in the report, it seems to be pointing to some Qt framework.

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: @rpath/QtWidgets.framework/Versions/5/QtWidgets
  Referenced from: /Users/USER/Downloads/*/Solarus Quest Editor.app/Contents/MacOS/solarus-quest-editor
  Reason: image not found

Nothing? I had a friend try to install it the other day on his machine and he had the exact same error (though I believe he was running 10.10.5, not 10.11). The good news is that I know the problem isn't on my machine. Unfortunately, that means there likely isn't much I can do to fix it...

Any thoughts?

I contacted vlag, who maintains the Mac OS X port.


There is indeed some known issues with the OSX port of the editor, the good news is that there is also a test version that should allow you to run it.

Could you just check if the keyboard works fine for you when running a quest through the editor ?

If the editor works and only has a problem with the "run quest" feature, this is far better than not opening at all.


Thanks gents. It does in fact load. However, you are correct in being concerned that the keyboard does not work.

It works fine if I just run Solarus 1.4.4 though, so I won't lose any sleep over it. Can't wait to dig into the new quest editor. It looks so much nicer.

Thank you both!

I'm new to solarus and I have the same problem and I can't get the quest editor to open any help?

Vlag should upload a fixed version today, stay tuned.

January 31, 2016, 10:23:26 PM #8 Last Edit: February 02, 2016, 02:35:53 PM by Christopho
Hi all,

Could you just confirm that this package runs fine on a non-developer OSX environment ?
If yes, it can be used as the official 1.4.5 Solarus quest editor :)

February 04, 2016, 12:05:52 AM #9 Last Edit: February 04, 2016, 12:11:49 AM by Jaace

I'm new here and was having trouble with the official latest 1.4.4 for OS X. This 1.4.5 package worked for me and I was able to open the Quest Editor with no issues so far -- but again, I just signed up and downloaded today so I may be missing something.

I'm having trouble running "Solarus" though, it's not opening for me.

Ok thank you :)

The Solarus package is actually just provided as a template in order to create your own package, and it is currently configured to run the sample quest (the quest to run is located in Solarus.app\Contents\Resources\data).
I'll check it tonight, thanks for your feedback !

Is it at least possible to create a quest with the Solarus Quest editor and run it with Solarus ?

I was able to open the Quest Editor but when I try to run from the editor it doesn't work (I can hear the music but cannot see the screen).

Also, when I tried just opening the runtime outside of the editor, even with the editor closed, it wasn't opening at all, no music or anything.

In 1.4.4 this was the opposite issue: runtime would open and sample quest worked but I couldn't open the Quest Editor.

Ok :(
I don't undestand why it is so complicated to have a Mac OS X port of Solarus, since the code is completely portable, including third-party libraries that are all widely used and free software.

And by the way, we don't care if there are keyboard or joypad issues when running the quest from the editor in 1.4. Input problems when running the quest from the editor are already fixed in the development version (1.5).