[SOLVED] Dialogue Box not appearing with a "dialogue not found" error

Started by ffomega, November 01, 2016, 04:47:00 AM

Previous topic - Next topic
I have run into an issue with the Youtube tutorial episode 9- Saving the game.

I have downloaded a copy of the resource pack, and have tried recreating your tutorial in this video using both my project as well as the LttP Sample quest.

I started the quest and when I press the D key to try and open the save game dialogue, I get this error:

Error: In on_paused: [string "scripts/game_manager.lua"]:19: bad argument #1 to start_dialog (No such dialog: 'pause.save_question')

The save menu also does not appear but the pausing function still works.

I checked game_manager.lua and the code was correct. 

18. function game:on_paused()
19.     game:start_dialog("pause.save_question")
20. end

I made sure an entry in the dialogue named "pause.save_question" was present.

I have seen other users who have received this error message regarding dialogue that were present in the editor, yet the game can't seem to see them.

I even made sure that all of the scripts were in the right place (since I literally tried recreating this tutorial from a fresh copy of the LttP resource pack that was provided in the video description of episode 9's video.

Has anyone been able to fix this problem?
My tilesets page can be found here:

It would be easier to troubleshoot if the error given was "language not set" rather than "no such dialog".

Thanks Chris xD

In code, I occaionally tend to overlook the comments since they are not to be used as actual code, and in doing so, overlooked the snippet of code "sol.language.set_language("en")", not thinking that all I needed to do was uncomment it >.<
My tilesets page can be found here: