Author Topic: Shaders unavailable [solved]  (Read 325 times)

0 Members and 1 Guest are viewing this topic.

Noobling
  • Newbie
  • *
  • Posts: 2
    • View Profile
Shaders unavailable [solved]
« on: April 03, 2021, 06:40:18 PM »
Howdy everybody. Since this is my first post, here's a bit of an introduction: I've been trying to get Solarus to run on a couple different computers and phew I am having a time of this. I'm entirely new to programming, and I'm really interested in the Solarus engine as a means to build on some ideas I've had kicking around in my head (for far too long. it's dangerous to have thoughts in your head too long, ya know).

Learned some Bash and C++ from codeacademy, I've ordered some of Ierusalimsky's books on Lua, but, this is all a bit cart-before-the-horse issues, given I can't even open Solarus!

So someone please throw me a bone.


THE PROBLEM

Trying to launch the sample quest (edit: or any other quest I've tried) displays the following in the console:

Quote
Info: Solarus 1.6.4 (6d2a11ddd)
Info: Opening quest 'C:/Users/Home-Computer/Downloads/solarus-x64-v1.6.4/sample-quest/'
Info: Joypad support enabled: true
Info: SDL: 2.0.12
Warning: failed to load framebuffer extension
Info: Failed to initialize SDL shader Hack. Shaders unavailable.
Info: Renderer: SDLRenderer : direct3d

On the principle of "try literally anything before you bug people for help," I've tried googling around and downloaded an openGL.dll to throw into the folder to see what happens. Predictably, since I am here, this did not help.

Question 1: What is going wrong here?

Question 2: How do I make it not go wrong?
« Last Edit: April 27, 2021, 04:49:31 PM by Noobling »

Noobling
  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Shaders unavailable [solved]
« Reply #1 on: April 27, 2021, 04:49:11 PM »
Turns out it was a graphics card issue - the hardware I have is unable to support OpenGL drivers.