Ocean's Heart

Started by Max, February 27, 2018, 01:59:34 AM

Previous topic - Next topic
This game looks very cute and the tileset in the other thread is VERY impressive! Before I play, I was wondering how "complete" you consider it to be as far as your intentions?

Tilesets and sprites are beautiful !

And I love the feeling when you hit an enemy.

Damn ! Your game has so much potential !

Thanks guys! Neovyse, I'm pretty happy with the sound effects and screen-shake. I've still got to come up with a better way to do it though because maps that aren't free-scrolling won't shake : /

Jojo- I think as far as "completion", there's a couple ways to answer that. I've been working on this game for a year, and I expect I'll finish it in about one more year (though maybe I'll get things done sooner, who knows!)(or maybe take longer. Who knows again, lol...)

As far as gameplay, I'll estimate there's about 3 hours of possible gameplay now. I'd like to have, when everything is done, around 7 hours. So content-wise, I'm about 45% done.

Does that answer your question?

I haven't finished testing yet, but 2 questions:
-I guess you haven't replaced all Zelda sounds yet, right? Or are some sounds very similar?
-The starting point was a test map with 3 entrances (in the version I downloaded). Which one is the best one to start? The demo should start in the correct room.

This game is the most beautiful thing I have ever played with Solarus. ;D
"If you make people think they're thinking, they'll love you. But if you really make them think, they'll hate you."

Thanks! : D

So yeah, I'm still working on creating new sound effects. It's a pretty time intensive process, but I enjoy it.

And yep, I forgot I accidentally left the initial game start in my debug room! The new file I uploaded fixes that and starts you in the game, as well as fixes the error llamazing encountered, which I think would prevent you from completing the game, idk.

If you stick with the old download for some reason, the door in the top-left goes to the start of the game.
(The top right goes to the first areas I created, to test game mechanics, and the hole is the one I use to go wherever I'm testing without going through the whole game :p)

March 06, 2018, 08:39:41 PM #20 Last Edit: March 06, 2018, 10:24:21 PM by Ezka
After lighting up the lighthouse I ended up dying outside of it, I then respawned stuck in this wall.
Its nothing too serious and was fixed by restarting the game but thought you should know none the less.

UPDATE: I am loving it so far, the graphics are beautiful besides for a few things that look off, and I'm loving the music. I have a few more questions though.

First off I'll report another error I ran into while playing, I am bad at describing things but it shows what I am talking about in the attached screenshot.

Second off is a question about controls, I am at the point where I need to place monster bait but I can't find a way to equip it, in the menu the only options are Save and Continue, Continue, and Quit. I might just be totally missing something, so feel free to make fun of me if I am.

One final question for anyone, I can't find a way to embed images in posts, I have tried googling it and I just can't find how to. If anyone could help me out on this that would be great!

I have not played too much yet and I am a bit lost. But here you have some comments:

1) I confirm the errors found by Ezka. I got these ones:
[Solarus] [340430] Error: No such dialog: '_crystal'
[Solarus] [1495160] Error: Illegal direction 3 for sprite 'entities/vase' in animation 'on_ground'
[Solarus] [1495160] Error: Illegal direction 3 for sprite 'entities/crystal' in animation 'orange_lowered'

2) Misprint in dialog: "The arrows you shoot with be..." -> "... shoot will be..."

3) The girl cleaning with broom outside in town: there are some letters of the text out of dialog box (text too long), and I think there was another misprint in her dialog, but I am not sure.

4) The funniest bug is that you can sell the same honeycomb inifinite times, and hence get rich in an instant.

Unimportant comments (of things that I think are not finished yet): you should not swim over boats but to walk over them, the menus do not show all info like keys and other stuff, a map will be very useful for not getting lost, a menu for deleting saved data will be useful for testers too. I am sure that you are aware of all these things. I will keep playing and sending you more feedback. ;D
"If you make people think they're thinking, they'll love you. But if you really make them think, they'll hate you."

Thanks for playing, guys!

Ezka, you can use the tag [ *img] and [*/img] with no * with a direct link to the image inside the tags. Also on imgur if you click on your image it automatically generated links for BBC code with the tags and your link. That's what I use.

Thanks for the error catches. The illegal direction errors just mean you created a sprite with <4 directions, so like the vase entity only has 1 direction (which is automatically right), and the entity is technically facing down. So it displays and works fine, but sends an error. The way you fix that is you just duplicate the direction so there's 4 and the error will go away, I just haven't bothered.

Ezka, the monster bait can only be used on certain stones- I haven't figured out how to make an equippable ites menu. Or a map screen for my menu... But anyway, you just go up to the certain stones and press spacebar. I should probably explain that better in-game. There's a guy in Crabhook Village that explains it, but he's kind of easy to miss and it's still a little obtuse. I'll make that better.

As far as respawning in the wall, I have no idea why that happens. Oh wait, actually I might, you said you died outside the lighthouse but respawned inside? I have an idea.

Last question, you said some of the graphics look off? Which ones? I'd love to fix them.

Diarandor, thanks for the error catches! A couple questions, do you remember what dialog had the typo about arrows? Who you were talking to?

Also, when you say swimming through boats, I don't have any plans for the player to ever learn to swim, my maps just aren't set up for it. Do you mean jumping off the dock and drowning in a boat? The issue is they're NPCs, so their hitbox is 16x16, lol.

Regarding a save-delete function, I was planning to get to that once I make a title screen. For anyone testing who doesn't know this, you can delete (or edit!) You save file by going to the location Solarus savegames are stored, finding the game folder, and manually deleting (or editing!) the file.

As far as design, I wasn't planning on ever having a map. It's a part of menus being to complicated to set up, I just decided I'd do that with my next game and leave it out of this one. Do you feel like a map is necessary for you? As the map designer, I have a hard time seeing the maps from another perspective.

Side note- I know a lot of people have posted on this forum essentially asking for more pre-made elements to come with Solarus (items, enemies, etc.). I agree somewhat with sentiments about how Solarus is for people who can code, however I think it would be nice to at some point,be able to release basically an empty game that had a menu, a few items, and maybe a couple enemies coded in. Is that kind of what Children of Solarus aims to be? If not, in a year or so I'd be willing to create such a thing, just an empty game with the systems set up (map, inventory, maybe three enemies, basic items), documented so they're easy to use.

March 07, 2018, 12:28:42 PM #23 Last Edit: March 07, 2018, 12:31:15 PM by Diarandor
3) I cannot remember which NPC was that, but it was a woman with broom in some town, and outside the houses. Both issues were in the same dialog.

A) Yes, drowning on a boat is the problem (I swam over them because I used the swimming item of the debug map). I suggest to put some walls in the docks next to the ships, to avoid jumping, or falling, over them.

B) I understand that making a perfect map of the game overworld would be a pain. But still, a rudimentary map showing ONLY in which area the hero is and how are areas connected would be very useful, and I recommend to add it. That is, a graph-like map, more or less, without exact positions and only showing in which area the hero is.
"If you make people think they're thinking, they'll love you. But if you really make them think, they'll hate you."

Cool, I think I've got all the errors you guys caught fixed (outside of the "illegal direction" errors.)

Diarandor, maybe something like the maps from Metroid? My main problem is my pause screen is running out of room, haha. Well, actually, so there's game:on_key_pressed()
Would something like this work? From the game_manager script?

Code (lua) Select

  if game:get_value("currently_map") ~= true
    sol.menu.start(game, "map_menu")

Yes, something like metroid would be perfect for the map. That is the idea.

Your code above will not work. You are calling on_key_pressed (and the syntax is wrong, the parameter must be a variable), and you need to define it instead. Be careful not to override that function if it is already defined elsewhere (you can also use the multievents script to avoid overriding it).
"If you make people think they're thinking, they'll love you. But if you really make them think, they'll hate you."

March 07, 2018, 10:09:34 PM #26 Last Edit: March 08, 2018, 03:10:18 AM by Ezka
Thanks for the help with the images, in the past I've tried that but when I pressed preview nothing showed up, must have to actually post for it to show :P

As for the graphical issues, I can't remember them all but I'll make sure to screenshot them if I do. The main one is in the sewers(might be named something else, I'm bad with names) with the water. The in corners don't seem to have tiles so it is just two tiles overlapping that look weird. And It also seems you are missing a tile for the out-corners.

That's all I can remember for now, but there is one other thing id like to report. In the following image you cant walk across simple plants like weeds and Lilly pads, I find that a bit strange.

Id also like to agree with Diarander in that a map would be super helpful. I don't think you have to make a perfect replica, in fact I feel like something that looks handmade would go more along with the story.

EDIT: Can you guys see the images, because I can't
EDIT2: Thanks for your help with the images, I feel so accomplished right now.

Quote from: Ezka on March 07, 2018, 10:09:34 PM
EDIT: Can you guys see the images, because I can't
Nope, we can't. :o
"If you make people think they're thinking, they'll love you. But if you really make them think, they'll hate you."

I checked, and when you click on an image on imgur, it comes up with like the zoomed-in screen, and there's a bunch of linking options on the right side. One is BBC code which works for me. I attached an image example code, because you can't type it out, because it will just try to make an image from it.

And yeah, you're spot on with the observation about the shallow water corners. It's totally just two sides overlapping, I didn't bother putting in the inside corner tile because I was trying to save a bit of time, I couldn't tell myself, but if someone else has noticed, I better do it properly, haha. You're also right in that I never made outside corners.

The plants being impassible isn't an error, just a choice I made early on and never thought about. I might go ahead and change them to passable now that you mention it.

Found a few more bugs.

If the pause menu is opened while the player is carrying something (like a flower or bush), then once the pause menu is closed again the player is unable to throw the item and the action button no longer works.

Got this error when the guy in Crabhook Village shows the player how to use monster bait
Error: In dialog callback: [string "maps/goatshead_island/crabhook_village.lua"]:81: attempt to index global 'crow' (a nil value)

When returning the charts to the chart shop in Ballast Harbor:
Error: In dialog callback: [string "maps/ballast_harbor/chart_shop.lua"]:51: bad argument #1 to start_dialog (No such dialog: '_game:quest_log_update')

The sensor to activate the charging pirate in the council_building map at Ballast Harbor should be larger so that the player cannot avoid stepping on it. I got through without stepping on it my first time and was confused about what was supposed to happen.

Is the player supposed to receive bombs when buying the coral ore from Honestbeard in Ballast Harbor? If it is intentional then there should be a follow-up dialog that explains it is intended.

When resuming a save sometimes music does not start (like when saving in a shop or other inside building in a town).

The battle with the rock spider (goat_tunnel_spider) in the Goatshead tunnels is a bit lame. The spider stands right in front of the door blocking the player from entering. The player can swing sword from doorway, but landing a hit causes the player to recoil back in to the previous room. Maybe have the door close behind the player as they enter the room?

Chest on far east side of Kingsdown contains 20 crowns that can be re-opened every time player enters map.

Dialog Typos:

Quote from: _goatshead.npcs.dockworkers.4I heard to tavern owner was looking
for him... something about money?

Quote from: _goatshead.npcs.tavern_people.adventurers.4need a Volunteer Navyman... person for
is to
clear out the beasts.
('is' should be 'us'?)

Quote from: _goatshead.npcs.ilex.1Don't worry about. I didn't know him that well,
he lived here watchinging the shrine.
('about' should be 'about it'?)

Quote from: _yarrowmouth.npcs.town_people.4
bIf you're looking for Briarwood Distillery, it's