Author Topic: [TUTORIAL] Trouble Installing a Tileset?  (Read 1390 times)

ffomega

  • Full Member
  • ***
  • Posts: 223
    • View Profile
    • Solarus Resource & Tutorial Site
[TUTORIAL] Trouble Installing a Tileset?
« on: December 18, 2016, 11:56:22 pm »
Hi guys!  I received a PM today on how to use one of my tilesets in their project, so I figured since I am answering the person's question, I would just make a copy of the tutorial for everyone else who might not know how to install a tileset.

First off, you must make sure you download both the tileset's image as well as the data file that has the same name:

For example, I'll use the Full Hyrule tileset:

Make sure you have these files located on your computer, or you can head to my website and download the tileset from there.

Full Hyrule.tiles.png
Full Hyrule.dat

You may choose to use the entities tileset as well, but in the case of Full Hyrule, it is optional).

Once you have the tileset and data file, find your game's project folder, and open data > tilesets



Place the files here as shown above.  Now open Solarus if you have not already.  Expand the list tree on the left under "tilesets".  You should see the "Full Hyrule.dat" file there.



Right-click it, and select "Add to Quest as Tileset"

A new dialogue box will open, giving you the option to rename the data file and give it a description.  By default, the information should already be filled in...but if not Do NOT make any changes and just press OK.



If everything was done correctly, the tileset will then appear in the directory tree of the quest with a 'windows paint' icon next to it, and it will open in the editor pane to the right



This is the same method you will use for each of my tilesets you wish to add.


Known bugs

I have not yet addressed to Christopho, and that is possibly due to the massive sizes of my tilesets.  There is a bug where, randomly, the tileset will not be picked up by Solarus during an edit.  Additionally, destructables appear to suffer the same bug, as when this bug occurs, random destructables--if not all--go back to their default "red pot" sprite.  Creating new ones on a map whose tileset still seems to appear will result in "default destructables" until Solarus is restarted.

Due to its size I am not sure if Solarus is capable of handling the tileset sometimes and it will often come back with a "Missing Tileset" error.  When looking at the crash report, it showed that the error was within the file "qt5widgits.dll".  Your only option is to save and quit, then restart Solarus if that happens.




If you run into this error, DO NOT click anywhere on your map otherwise Solarus will crash.  Just save and quit, then reopen Solarus.

I will have to make a note to inform Chris about this issue, as he may want me to open a Github bug report.

I hope this helps solve your issue with the tilese(s) you wish to use :)
My tilesets page can be found here:
http://absolute-hyrule-tutorials.solarus-games.org/

MetalZelda

  • Hero Member
  • *****
  • Posts: 551
    • View Profile
Re: [TUTORIAL] Trouble Installing a Tileset?
« Reply #1 on: December 19, 2016, 02:06:09 am »
The tutorial is good but using Windows XP in 2016 ?  ???

ffomega

  • Full Member
  • ***
  • Posts: 223
    • View Profile
    • Solarus Resource & Tutorial Site
Re: [TUTORIAL] Trouble Installing a Tileset?
« Reply #2 on: December 19, 2016, 03:30:35 am »
What you talking about? You're looking at Windows 7 my dude xD nah just kidding lol

But seriously, I Absolutely use Windows XP for compatibility reasons.  I know there are a ton of people out there (more than are probably willing to admit) that still use this operating system, and it has rarely let me down when it comes to creating projects and whatnot :)  Also, to be fair I do have Windows 10 on my desktop machine XD
My tilesets page can be found here:
http://absolute-hyrule-tutorials.solarus-games.org/