Author Topic: Failed to run 1.4.5 under OSX  (Read 2061 times)

sandstrand

  • Newbie
  • *
  • Posts: 6
    • View Profile
Failed to run 1.4.5 under OSX
« on: July 13, 2016, 04:34:42 pm »
Has anyone tried running the downloaded package for 1.4.5 under OSX? Simply running the solarus.app does not work for me, nothing happens.

I have no real experience with OSX packages so I don't know what is wrong but the Contents/MacOS/Solarus file does not seem to be natively executable.

Update:

Copying the .dylab and .framework files to /usr/lib and /Library/Frameworks respektively seems to allow for the solarus.app to launch but when I replace the data folder in the package with my own project's data folder the solarus.app launches to a halted window. However, if I launch with /Contents/Resources/solarus_run it works.

Any ideas?
« Last Edit: July 13, 2016, 06:08:33 pm by sandstrand »

Christopho

  • Administrator
  • Hero Member
  • *****
  • Posts: 1173
    • View Profile
Re: Failed to run 1.4.5 under OSX
« Reply #1 on: July 13, 2016, 08:59:41 pm »
I don't understand anything about Mac OS X but as far as I know, the packaging was fixed and should now work. There is a readme file that explains how to use it.

Christopho

  • Administrator
  • Hero Member
  • *****
  • Posts: 1173
    • View Profile
Re: Failed to run 1.4.5 under OSX
« Reply #2 on: August 24, 2016, 10:45:07 am »
Hi,
There is now an 1.5 Mac OS X package: http://www.solarus-games.org/downloads/solarus/macosx/solarus-1.5.0-macosx64.zip
Feel free to report any problems.

llamazing

  • Full Member
  • ***
  • Posts: 191
    • View Profile
Re: Failed to run 1.4.5 under OSX
« Reply #3 on: August 28, 2016, 05:43:51 pm »
I get the following error when launching the Quest Editor from the 1.5 OSX package:

Quote
Could not locate the assets directory.
Some features like creating a new quest will not be available.
Please make sure that Solarus Quest Editor is correctly installed.

I can load existing quests, but it doesn't let me create a new one. The 1.4.5 version of the Quest Editor did not have this problem.

I found an assets directory included with the Windows build. Copying that assets directory over to the directory containing the OSX Quest Editor does not fix it. I also tried copying that assets directory to ~/Library/Application Support/Solarus where the saved games get stored, but that did not fix it either.

Any ideas?

sandstrand

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Failed to run 1.4.5 under OSX
« Reply #4 on: November 09, 2016, 01:46:15 pm »
We had this issue under 1.5 as well but found a solution.

The problem, if anyone is interested, was due to our quest trying to write a settings.dat, a filename already created by solarus at each run, and in the same directory.