Author Topic: strange bug.  (Read 2308 times)

patrick81

  • Newbie
  • *
  • Posts: 3
    • View Profile
strange bug.
« on: July 27, 2014, 08:26:27 pm »
Device: GCW Zero
Software: Soarus 1.1.0
Game: ZSDX 1.7.0

I think i found one MAJOR bug.  I def don't think it's normal. lol  I happened to fall in the hole and it took me to a completely different place.  First I think i was in East Palace.  When i walked out of the room, it took me to Swamp Palace... walked out again, it took me to Desert Palace.. then Hyrule Castle.   I kept walking and walking to many strange places and I couldn't get out!!!!   :o  I think it's really funny!!! haha

Here's the bug i found. 

This is the cave I went in....






Then I fell there



Make sure you save beore you fall.  GOOD LUCK!   ;D



 

Renkineko

  • Jr. Member
  • **
  • Posts: 81
    • View Profile
Re: strange bug.
« Reply #1 on: July 27, 2014, 09:33:18 pm »
This bug has been fixed on the 1.2.0 version of the engine and 1.8 version of the quest. About the link between all the palaces, it's not a bug, but at this point of the game you are not supposed to get here :)

patrick81

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: strange bug.
« Reply #2 on: July 27, 2014, 09:57:45 pm »
oh okay thanks for telling me this.  It was pretty fun tho.  lol  ;D

Christopho

  • Administrator
  • Hero Member
  • *****
  • Posts: 1179
    • View Profile
Re: strange bug.
« Reply #3 on: July 27, 2014, 10:00:39 pm »
Hum, if you are playing on GCW-Zero, ZSDX 1.8 is not available yet.
If you are stuck because you saved there, you can send me your savegame and I will fix it.

patrick81

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: strange bug.
« Reply #4 on: July 27, 2014, 11:35:20 pm »
it's all good!  I'm glad i saved it before this happened.   ;D  i'm just loving this game!  the only thing that annoys me a bit is the slowness.  1.8 already came out?  I only see 1.7 for GCW on your site. 

edit:  sorry i read it fast.  gotcha.  can't wait for the next version.  :D
« Last Edit: July 27, 2014, 11:48:17 pm by patrick81 »

Christopho

  • Administrator
  • Hero Member
  • *****
  • Posts: 1179
    • View Profile
Re: strange bug.
« Reply #5 on: July 28, 2014, 10:51:28 am »
According to http://forum.solarus-games.org/index.php/topic,21.msg239.html#msg239, they are working on the ZSDX 1.8 port for GCW-Zero and it runs much faster than before.
This is thanks to SDL2 and LuaJIT.