Author Topic: Running the quest...?  (Read 2441 times)

aLinktotheDead

  • Newbie
  • *
  • Posts: 11
    • View Profile
Running the quest...?
« on: July 08, 2015, 11:26:36 am »
Hello, I am a new user of Solarus/Solarus Forums and I am currently working on my first game on Solarus called The Legend of Zelda: Darkest of Times and I need help running it because apparently my map will not open ingame. Please help so I can continue working on my game.

Christopho

  • Administrator
  • Hero Member
  • *****
  • Posts: 1172
    • View Profile
Re: Running the quest...?
« Reply #1 on: July 08, 2015, 11:33:12 am »
Hi,
Did you watch the first video tutorials? http://wiki.solarus-games.org/doku.php?id=video_tutorial
If yes, can you give more details about your problem? Is there an error message or an error.txt file?

aLinktotheDead

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Running the quest...?
« Reply #2 on: July 08, 2015, 11:34:56 am »
Yes, I have watched the tutorial video, but all I know is that it is outdated and literally old, so it probably won't work for me that well, but anyways, I don't have an error.txt file so I know I'm doing something wrong? Whenever I run my quest up, it just cuts to a black screen.

Christopho

  • Administrator
  • Hero Member
  • *****
  • Posts: 1172
    • View Profile
Re: Running the quest...?
« Reply #3 on: July 08, 2015, 11:49:19 am »
Everything in the video tutorials is still relevant, it is just that some files that had to be edited by hand (quest.dat and dialogs) can now also be edited graphically.
Do you have a black screen as soon as you run solarus, or do you see at least the solarus logo?

aLinktotheDead

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Running the quest...?
« Reply #4 on: July 08, 2015, 11:52:07 am »
I do see the Solarus Logo, then it just shows a black screen, nothing else.

Christopho

  • Administrator
  • Hero Member
  • *****
  • Posts: 1172
    • View Profile
Re: Running the quest...?
« Reply #5 on: July 08, 2015, 12:07:23 pm »
Ok, then I recommend you to watch the video tutorial part 2 about running your first map. There is nothing outdated in this one.
https://www.youtube.com/watch?v=LALfp7c6rto&list=PLzJ4jb-Y0ufwPrBfO5AQMRfe2kLABQsF0&index=2

aLinktotheDead

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Running the quest...?
« Reply #6 on: July 08, 2015, 12:12:22 pm »
You mean I have to edit them by hand in order to get it working? Plus, the quest.dat is totally different from the video!
Also, suddenly message that pops up to the point that it crashes Quest Editor.
« Last Edit: July 08, 2015, 12:19:40 pm by aLinktotheNothing »

Christopho

  • Administrator
  • Hero Member
  • *****
  • Posts: 1172
    • View Profile
Re: Running the quest...?
« Reply #7 on: July 08, 2015, 12:17:45 pm »
You have a choice to edit quest.dat:
- You can do it by hand like the video shows.
- Or you can do it from the graphical quest properties editor. To open it, right-click on your quest in the left tree (the root element) and click Edit.

The second option is more straightforward. I recommend to set the title of the window, the write directory for savegames and to keep default values for the rest.
If you have a doubt about the result, don't hesitate to paste your quest.dat here :)

Christopho

  • Administrator
  • Hero Member
  • *****
  • Posts: 1172
    • View Profile
Re: Running the quest...?
« Reply #8 on: July 08, 2015, 12:24:37 pm »
Wow, about the runtime error, this looks like a Solarus bug. Can you send me your data directory, so that I can reproduce the crash? I need the exact data that reproduce the crash to be able to fix it.

aLinktotheDead

  • Newbie
  • *
  • Posts: 11
    • View Profile
« Last Edit: July 08, 2015, 01:06:08 pm by aLinktotheNothing »

Christopho

  • Administrator
  • Hero Member
  • *****
  • Posts: 1172
    • View Profile
Re: Running the quest...?
« Reply #10 on: July 08, 2015, 01:07:03 pm »
There is a black screen simply because your main script does nothing after the solarus logo. You never start a game so nothing happens. See chapter 2 about running your first map.

Also, in the quest properties, the write directory should be a simple name, never a path. For example, loz_darkest_of_hours.
Here is how it works: all games using solarus, and not only yours, store their savegames in a subdirectory of $HOME/.solarus, where $HOME is the home directory of the user (like C:\Users\test1 in your case). This write directory thing is the name of the subdirectory your game wants to use. If you set it to loz_darkest_of_hours, savegames of your game will be stored in C:\Users\test1\.solarus\loz_darkest_of_hours. The only goal of the write directory is to avoid conflicts between different Solarus games installed on the same computer.

The crash was probably because you had backslashes in your write directory. We will fix that.

I hope it helps!

aLinktotheDead

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Running the quest...?
« Reply #11 on: July 09, 2015, 07:04:21 am »
Thanks for da help, I got my game workin' and I'm ready to make a dark Legend of Zelda game!