Author Topic: Zelda resources pack error  (Read 1372 times)

andreatux

  • Newbie
  • *
  • Posts: 3
    • View Profile
Zelda resources pack error
« on: January 15, 2015, 01:59:07 pm »
Hello everybody,

as written in the readme file in the zelda resources pack, I opened the quest editor and created a new quest. Once the editor was closed, I copied the content of the repository "data" folder into my newly created quest "data" folder, overwriting project_db.dat file. However, if I open the quest with my quest editor, it won't load any tileset, giving me an error "cannot load [file.dat] bad argument: number expected, got a string". In fact, in each tileset "dat" file,  after some point I have the field "id" filled with strings instead of numbers, like:

tile_pattern{
  id = "barrier.2",
...
}

How can I solve this problem? I have downloaded the 1.2 MacOsx version of the engine.

Thanks.

Christopho

  • Administrator
  • Hero Member
  • *****
  • Posts: 1172
    • View Profile
Re: Zelda resources pack error
« Reply #1 on: January 15, 2015, 02:31:58 pm »
Hi,
The ALTTP resource pack is only compatible with version 1.3 of the engine.

andreatux

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Zelda resources pack error
« Reply #2 on: January 15, 2015, 06:49:15 pm »
Oh, okay thanks very much!

andreatux

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Zelda resources pack error
« Reply #3 on: January 15, 2015, 08:52:27 pm »
Is there a specific reason why the mac version is still at version 1.2?

Christopho

  • Administrator
  • Hero Member
  • *****
  • Posts: 1172
    • View Profile
Re: Zelda resources pack error
« Reply #4 on: January 15, 2015, 09:48:18 pm »
The Mac OS X version usually comes after the Windows version. We are working on it, we should be able to release it very soon. Sorry for the inconvenience!