Author Topic: Gles2 error message  (Read 169 times)

20degree

  • Jr. Member
  • **
  • Posts: 87
    • View Profile
    • Sylvain Personnal Website
Gles2 error message
« on: April 21, 2019, 07:04:32 pm »
I have first done a search with the word "gles" to see if some other people would have the same problem as me. Since i have not found about the subject, i think that it could be of importance for peoples that might have the same problem as i.

Here i have and old laptop Win7 64bits. The error message it give me ive notice that it is written:
Couldn't load GLES2 function
GL 3.x is not supported

How can i make Solarus version 1.6 work then?

What would be the "steps" to make Solarus Work?

Does it exist some free full software that could make it work and how to install the software that could help?

Thank's for your time.

A+

20degree

  • Jr. Member
  • **
  • Posts: 87
    • View Profile
    • Sylvain Personnal Website
Re: Gles2 error message
« Reply #1 on: April 21, 2019, 07:42:40 pm »
I have found a solution.

I have gone to:
https://fdossena.com/?p=mesa/index.frag

then i have clicked on the button icon "windows", downloaded the file.

After i have extracted the file, there is an "opengl32.dll" file into the folder.

I have simply copied the "opengl32.dll" file into the directory of Solarus v1.6, where there is the (shield), (gamepad) icon software.

Next i simply open the Solarus Developper v1.6 and "It Work".

I'm happy with it because i can run and test creations made with Solarus v1.6

stdgregwar

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: Gles2 error message
« Reply #2 on: May 20, 2019, 10:23:12 pm »
A very late thank you to you 20degree.

This is a very usefull feedback.

Sorry to not have answered sooner.

Greg