Author Topic: Installing in Ubuntu  (Read 133 times)

bonez001

  • Newbie
  • *
  • Posts: 7
    • View Profile
Installing in Ubuntu
« on: October 21, 2018, 09:35:46 am »
Hello everyone. Its kinda hard to find straight forward directions for installing solarus and the editor in ubuntu 16.04. ANyone there who can help me?

PeterB

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Installing in Ubuntu
« Reply #1 on: October 31, 2018, 11:22:07 pm »
Hey bonez001, I installed 1.60 in Lubuntu the other day.

Before you install the editor you need to install the following.

libsdl2-dev libsdl2-image-dev libsdl2-ttf-dev libluajit-5.1-dev libphysfs-dev libopenal-dev libmodplug-dev libvorbis-dev qtbase5-dev qttools5-dev qttools5-dev-tools libglm-dev

Either use apt-get install or use Synaptic, which is what I did, finding each file and installing it.

Download 1.60 from here - https://gitlab.com/solarus-games/solarus-quest-editor

Click on the little cloud icon next to 'find file'. Extract the files, I put mine on the desktop, in the created folder create a new folder called build, go into it and open a terminal.

type cmake ..

then type sudo make and put in your sudo password. This should install the editor.

You can run it by typing ./solarus-quest-editor or by adding a short cut to your desktop, pointing it to the executable (solarus-quest-editor) in the location where it is installed. (sorry forgot where it goes)

You can then do the same for the engine. Download it from https://gitlab.com/solarus-games/solarus but do a make install at the end, again as sudo. Then there should be a shortcut in your programme menus if everything goes ok. Mine appeared after I rebooted.

Any problems let me know.

« Last Edit: October 31, 2018, 11:31:32 pm by PeterB »

Christopho

  • Administrator
  • Hero Member
  • *****
  • Posts: 1144
    • View Profile
Re: Installing in Ubuntu
« Reply #2 on: November 01, 2018, 09:39:40 am »
That's correct PeterB but Solarus needs to be installed before Solarus Quest Editor (because Solarus Quest Editor needs Solarus).
Note that you are talking about installing the development version: 1.6, which is not released yet. Do this at your own risk :) Unless you need a development version for a specific reason, you should normally installed the latest stable release.

PeterB

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Installing in Ubuntu
« Reply #3 on: November 01, 2018, 10:21:26 am »
Good point, thanks Christopho.  I forgot i installed the quest launcher first. :)

Here are the links for the stable release (1.5.3)

Solarus Quest Launcher - https://github.com/solarus-games/solarus/releases/tag/v1.5.3

Solarus Quest Editor - https://github.com/solarus-games/solarus-quest-editor/releases/tag/v1.5.3

Good luck.