Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Thalassius

Pages: [1]
1
Bugs & Feature requests / Re: High CPU usage.
« on: April 17, 2016, 12:04:01 am »
Oh good idea!!!  :)
I'll do it and I'll be back!

For the time being, as I mentioned earlier, the Win 32 version runs with ~70% of my cpu occupied (at win 10 x64 and at Linux Mint with Wine v.1.7.55 (the latest Wine version available for Ubuntu LTS)).
G.

2
Bugs & Feature requests / Re: High CPU usage.
« on: April 16, 2016, 07:15:00 pm »
I use Solarus v1.4.4 and this does not happen to me on Ubuntu Precise Cinnamon environment. It did happen to me on Linux elementary OS Luna (based off of Ubuntu precise).  It might have to do with your theme or skin. When running Gimp on Ubuntu it lagged like crazy until I changed the Dark theme. Themes can cause leaks with applications and that is what is happening or maybe a glitch.
Hmm..... ???
I'm using KDE (not a GTK based desktop), so I doubt that changing the skin, will actually help.
An...yes! Ubuntu LTS is based on Debian beta, so there are many glitches!
Some time I'll have to return to the stable Debian version, I just don't have the time to install everything from the beginning, right now.

Windows beyond XP or 7 are still buggy.
I agree, but since my main system is the Linux one, I'm still leaving Win 10 to be (instead of installing a better earlier version). The only use of Win for me, is for games.  :)

3
Bugs & Feature requests / High CPU usage.
« on: April 16, 2016, 11:02:54 am »
Hi!  :)

Running Solarus at my system (dual proccessor Athlon 5GHz), stacks cpu usage at 100% resulting in overheating after a few minutes.

My primary system is Linux (Mint 17.3 x64 KDE) and Solarus takes 50%  and while it's running, Xorg also takes >30% and some other proccesses (eg. plasma) also taking  many cpu cycles, so my system is always at 100% while Solarus is running.  :o

I also tested Solarus at Win 10 x64. The high cpu usage still occurs, but it isn't so intense.
Still needs a ~ 70% of cpu cycles.  ???

Is it normal or something went wrong here?
TIA!  :)
G.

4
Bugs & Feature requests / Re: Problem after compiling the code.
« on: April 14, 2016, 07:26:27 pm »
GREAT!!! That did the trick!
THANKS!!!  ;D
G.

5
Bugs & Feature requests / Re: Problem after compiling the code.
« on: April 14, 2016, 04:33:14 pm »
Yes, I installed it, as root.
(I gave "su -" for becoming root and issued "make install" from there.

I noticed that installation is optional and upon a successful compilation I could fire "solarus_run" from the build directory, so I did it (before installation).
It gave me the same output (solarus_run: error while loading shared libraries: libsolarus.so: cannot open shared object file: No such file or directory).

Just a question here: Is libsolarus library x64 arch?
If it depends on 32bit binaries, it could explain this message (because latest ia32 version on xUbuntu systems are more or less, broken).  ???
(32bit is a foreign architecture at my system).

6
Bugs & Feature requests / Problem after compiling the code [SOLVED].
« on: April 14, 2016, 01:33:27 pm »
Hi!  :)

I downloaded Solarus code, I installed the dependencies and I compiled it successfully.
However, giving "solarus_run" at console, returns: "solarus_run: error while loading shared libraries: libsolarus.so: cannot open shared object file: No such file or directory".

I'm on Mint 17.3 x64 KDE (Ubuntu LTS based).

Any hints?  :)
TIA!
G.

7
Zelda Mystery of Solarus DX / Debian repository is down!
« on: April 14, 2016, 12:22:04 am »
Hi!  :)

Debian repo is off-line and returns an "HttpError429. Some index files failed to download".

PS. The Windows port seems to run OK with Wine.

Bye!  8)
G.

Pages: [1]