Solarus Forum

Solarus => Development => Topic started by: kaboth on September 03, 2018, 01:15:05 am

Title: Help with enity reverting back to default
Post by: kaboth on September 03, 2018, 01:15:05 am
My problem is when I try clicking save after changing the enitys graphic it switches back to the default every time, please help.
Title: Re: Help with enity reverting back to default
Post by: Diarandor on September 03, 2018, 01:18:25 am
You mean in the Editor or while the game is running? Could you give us more info?
Title: Re: Help with enity reverting back to default
Post by: kaboth on September 03, 2018, 01:22:46 am
when I change the graphic to the splash effect tile in the full hyrule tileset I step on the water and get the bottom of a sign each time, when i change the graphic to the water and save it will just revert back to the same sign graphic each time. sorry If I'm confusing if i had a video I would show it but I have no recording software.
Title: Re: Help with enity reverting back to default
Post by: Diarandor on September 03, 2018, 01:28:03 am
So you mean that the Editor is not saving your changes? Did you try "Ctrl" + "s" to save the changes wherever you are doing them? I cannot understand the problem if you don't explain it better.
Title: Re: Help with enity reverting back to default
Post by: kaboth on September 03, 2018, 01:38:51 am
made a video with fraps and uploaded it to youtube. https://youtu.be/h0LQW2eOv4Y that's what happens when i stand on the water and when i change the graphic it wont save at all.
Title: Re: Help with enity reverting back to default
Post by: Diarandor on September 03, 2018, 01:46:06 am
Ok, so you are trying to change the sprite for water under the hero, and you changed the image, so all seems ok to me. But what do you mean by "it won't save at all"?
Title: Re: Help with enity reverting back to default
Post by: kaboth on September 03, 2018, 01:48:32 am
i wanted it to save the water under the hero graphic instead on the one in the video, and it wont let me save it or it will revert back to that crappy graphic.
Title: Re: Help with enity reverting back to default
Post by: Diarandor on September 03, 2018, 01:53:58 am
Ok, I see the problem with the incorrect sprite. I think you didn't update the sprite that defines that animation (look for it in the quest tree of the Editor). You have to find it and update its coordinates for the image.
Title: Re: Help with enity reverting back to default
Post by: kaboth on September 03, 2018, 02:08:46 am
the source image keeps changing to the one i don't want.
Title: Re: Help with enity reverting back to default
Post by: Diarandor on September 03, 2018, 08:50:00 am
The source images are not changed by the engine. You need to update your sprite (the sprite is not the png source image!).